Child pages
  • Workbench Glossary
Skip to end of metadata
Go to start of metadata


Active tab is the currently selected viewing tab at the top of the Workbench Window. The Overlay and Features Toolboxes provide options for viewing that apply only to the Active tab. 


Brainordinate is a brain location that is specified by either a surface vertex (node) or a volume voxel.  Brainordinates include grayordinates (gray-matter vertices or voxels) and whiteordinates (white matter voxels).  CIFTI files contain a list of brainordinates and can handle combined surface/volume representations. 

 

CIFTI is a file format that stores data from surfaces (vertices) and volumes (voxels) concurrently in a single file comprising a listed set of brainordinates. A CIFTI file can contain multiple non-overlapping volume components with different structures, where each volume component is any selected list of voxels (e.g., only left thalamus voxels).  These components need not fill the entire grid of ‘N x M x O’ volumetric dimensions.  A CIFTI file can also include multiple surface components with different structures (most commonly, the left and right cerebral cortex), but the surface geometry is not specified in the CIFTI file (commonly, the geometry is in a separate GIFTI surface file). See http://www.nitrc.org/projects/cifti/ for a detailed exposition of the CIFTI-2 file format.

CIFTI files are based on the NIFTI-2 file format and therefore have a filename extension ending in .nii.  Workbench currently supports many types of CIFTI files, including dense scalar (*.dscalar.nii), dense data series (*.dtseries.nii), dense connectome (*.dconn.nii), and dense label (*.dlabel.nii), where the term 'dense' refers to having a value at each listed brainordinate (as opposed to a parcellated file such as *.ptseries.nii, where each value is shared across many brainordinates). Files in the now-deprecated CIFTI-1 format are still supported by Workbench and can be converted to CIFTI-2 using wb_command -cifti-convert -version-convert.

 

ConnectomeDB is the web-accessible database for organizing and distributing all HCP data modalities (MR images, MEG, and behavioral data) and will be central to HCP data mining.  ConnectomeDB is accessible from any web browser (https://db.humanconnectome.org) and linked from the Connect Menu within Workbench.

 

Dense Time Series file contains BOLD activation maps for each timepoint in the resting state fMRI time series. A dense time series can be viewed as single maps at given timepoints or as a movie of sequential timepoint maps using the animate function in the Toolbox Connectivity tab.  A dense time series can also contain columnar brainordinate data of any kind (e.g. each column may contain an ICA component, a task activation map, etc.).

 

Dense Connectome refers to connectivity matrix files that contain correlations between every surface or volume brainordinate and every other surface or volume ordinate in our model of the brain. These files are REALLY big (~30 GB for current resolution). Therefore, they are kept in the HCP database ConnectomeDB, which can access these large files as needed to view connectivity maps of interest.  Dense connectomes can also be asymmetric, such as a structural connectivity matrix between grayordinates (all gray matter strucures) and whiteordinates (all white matter structures).

 

Features Toolbox refers to the section of the Workbench Window that allows the user to select and set display attributes for Features such as Borders and Foci in the current Active Viewing tab. 

 

GIFTI is a file format for surface representations that is supported by all major brain mapping visualization platforms (http://www.nitrc.org/projects/gifti).

 

Grayordinate is a brain gray matter location that can be represented by a surface vertex (node) or a volume voxel. Grayordinates represent a subset of all brainordinates.

 

Menu bar refers to the gray bar containing pulldowns (menus) of program-wide functions located at the very top of the screen (Mac) or at the top of the Workbench Window (PC and Linux). Menu items include File, View, Data, Surface, Volume, Window and Help.

 

NIFTI (*.nii and *nii.gz) is a standard file format for volumetric data that is widely used in neuroimaging.  The original NIFTI-1 file format was based on 16-bit signed integers and was limited to 32,767 in each dimension. The NIFTI-2 format (http://www.nitrc.org/forum/message.php?msg_id=3738) is based on 64-bit integers and can handle very large volumes and matrices.

 

Overlay Toolbox refers to the section of the Workbench Window that allows the user to set the data to be displayed on the structure in the active tab. 

 

Scene refers to the current state (settings and files being visualized) within Workbench. You can save these settings globally in a scene file, which allows you to re-access your current Workbench session at a later time. By reopening a saved scene file, a user can “pick up where they left off” when they reopen Workbench.

 

Specification File (commonly called “Spec File”) is a file used to organize a set of data files (such as volume, label, and metric files) to be loaded into Workbench.


Splash Screen is the first window that opens upon launching Workbench that serves as a title page and shortcut for opening Spec files. It contains a list of Spec files in your current path and those that have been recently opened that can be selected and opened in one step. It also contains links to the HCP website and Twitter feed.  

 

Surface Montage is a viewing mode in which lateral and medial views of both left and right hemispheres are shown in a single viewing area and can be rotated in tandem for a full surface view of the brain.

 

Tile Tabs is a setting that displays the images from all of the tabs you have open in the current Workbench Window in one Viewing Area.  All the surfaces and/or volumes displayed in Tab Montage can still be manipulated with the mouse controls (rotate, zoom, pan).  This option allows you to view and compare multiple structures and datasets at once. Access tab montage from the ViewScreen menu, or through the keyboard shortcut: command + M (Mac) or control + M (PC/Linux). 


Toolbar refers to the section at the top of the Workbench Window that contains viewing settings for the structure you are displaying in the current tab and access to Workbench functional modes (border drawing, region of interest definition, etc.).

 

Toolbox refers to the section of the Workbench Window that allows for data specific selections and provides information as the user interacts with the structure in the active tab.

 

A Tooltip is pop-up information on Workbench functions that appears when you hover your cursor over a button or pull-down menu.  These are found throughout the entire Workbench for easy access to explanations of the functions of buttons and menus. 

 

Viewing Area refers to the field of the Workbench Window where images of the surface, volume or whole brain are displayed.  The default background is set to black, but this can be changed to any color in the Preferences.

(Menu barWorkbenchPreferencesColorsSet Background…)

 

Viewing Tabs refer to the set of viewing workspaces within a Workbench Window. Each tab contains an independent Toolbar, Viewing Area, and Toolbox. To navigate between Viewing Tabs, click on the tab name or press command (Mac)/control(PC/Linux) and the left and right arrow buttons. To remove a tab, click on the ‘X’ button to the right of the tab name. Further tab options are available in the Window menu.


Volume Montage is a setting available in Volume views that displays a series of slice images in the Viewing Area.  Settings for the number of columns and rows, and the step number (stereotactic space between) of slices being viewed for this montage of images are located in the Toolbar.

 

Whiteordinate is a brain white matter location.  It is generally represented by a white matter voxel, though in principle, it can also be represented by a surface vertex (node). Whiteordinates represent a subset of all brainordinates.  In a CIFTI file, a list of whiteordinates need not fill the entire grid of the ‘N x M x O’ volumetric dimensions.

 

Workbench Window refers to the main interface of Workbench, containing the Viewing Tabs, Toolbar, Viewing Area and Toolbox. In PC/Linux, the Workbench Window also includes the Menu bar. More than one Workbench Window can be opened at one time, either by selecting New Window from the File menu or from selections made from the Window menu.


  • No labels